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EXPERT EDITOR

Expert Editor of ExpertPRIZ allows to create and update expert
knowledge bases, which are used by the Expert subsystem in
ExpertPRIZ applications.

1. Basic concepts

Attribute - a factor or feature of the problem under
consideration. It has a name, e.g. AGE, COLOUR OF EYES, etc. It
can also have a related text: a question or an explanation, e.g.
"How old is the candidate for the job?". In addition to that,
attributes have some values, e.g. AGE can be "over twenty",
"under twenty", "under sixteen" etc. An attribute can also
express a solution of a problem, e.g. "Accept the candidate for
the job". In this case the attribute is called a result
attribute.

Example - a condition with a certain conclusion. The condition
is a conjunction of attribute values. The conclusion can be a
decision, a diagnosis, a piece of advice, etc. Thus, the examples
consist of decisions and the factors involved in the decision.
Each example describes a particular situation. If in a certain
situation there are some factors with no influence to the
conclusion, then the appropriate example has special don't care
values ("-") corresponding to these attributes.

For describing a problem, usually a set of examples is needed.
This set of examples is called expert knowledge base.

Suppose our problem of selecting candidates for a certain job
can be described by means of attributes AGE, COLOUR OF EYES,
RESULT. Suppose our expert knowledge base consists of the
following examples, which correspond to particular cases:

If he/she is over twenty and has brown eyes, then accept.
If he/she is over twenty and has blue eyes, then don't accept.
If he/she is under twenty and has blue eyes, then accept.
If he/she is under twenty and has brown eyes, then accept.

Here is the same in the form of a table:

AGE COLOUR OF EYES RESULT
1 over twenty brown accept
2 over twenty blue don't accept
3 under twenty blue accept
4 under twenty brown accept

Every set of examples has an underlying pattern, or an expert
rule hidden in it. This rule is called a decision tree. E.g. our
set of examples yields the following decision tree:



AGE:
-over twenty---COLOUR OF EYES:

-brown----——---—-- RESULT:
-accept
-blue---=-=====-- RESULT:

-don't accept

-under twenty--RESULT:
-accept

Having prepared this expert knowledge base by means of Expert
Editor, and having also supplemented the attributes with
explanatory texts, you get an expert system which can help you in
selecting candidates for the job. You can start a consultation
course with it through ExpertPRIZ. During the consultation, the
decision tree is followed from the root node (the attribute AGE)
to some leaf node (RESULT). The path is determined by the answers
the user selects to the questions of the expert system. In more
complicated situations the behaviour of an expert system may also
depend on results of computations carried out during the
consultation course.

2. Expert Editor main window and menu

Expert Editor allows editing one expert knowledge base file at
a time. A new expert knowledge base has one attribute (the result
attribute) and an empty example by default.

In the main window of Expert Editor there are following child
windows:
1) an edit window for the Title of expert knowledge base;
2) an edit window for the Texts related to the attributes;
3) a listbox for the values of the attributes;
4) Examples window for the table of attributes and examples, or
Decision Tree window for the decision tree generated from the set
of examples.

You can change the input focus between these windows using
mouse click or the Tab key.

NB! For better understanding of the facilities of Expert
Editor, try to open the CONIFERS.EXP expert knowledge base file
from the set of files of demonstration of ExpertPRIZ. For that
purpose choose Open from the File menu. After that choose the
DEMO subdirectory and the CONIFERS.EXP filename in the Open
Knowledge Base dialog box.

In the Title window you can see the heading text of this
expert knowledge base. The contents of the Texts and the
Valueswindows depend on the currently selected cell in the table
of the Examples window, i.e. you can see the text and the list of
values of the attribute to which the selected cell (attribute
value or name) belongs.



The main menu of Expert Editor has three submenus: File, Edit
and Help. The File and Help submenus are standard File and Help
submenus of a Windows application. The Edit submenu supports
standard Cut, Copy and Paste facilities for the edit windows. In
addition, it has special features for editing attributes and
examples, and also for viewing the decision tree, optimizing and
testing the expert knowledge base.

The File menu contains the following commands.

New - creates a new (untitled) expert knowledge base. A new
expert knowledge base has one attribute (named RESULT) and one
empty example by default.

Open - opens an existing expert knowledge base.

Save - saves the expert knowledge base currently open under
its previous name. If the name was (untitled), asks for the file
name.

Ssave As - saves the expert knowledge base currently open under
a new name.

Print - prints the expert knowledge base currently open. If
you have the Examples window on the screen, prints the contents
of the expert knowledge base in tabular form, in case of the
Decision Tree window - prints the tree. A tree 1is printed
starting from the node currently selected (i.e. it is possible to
print subtrees as well as the whole tree).

Page Setup - allows to format pages for printing.

Printer Setup - allows to set up printing options.

Exit - quits the working session with Expert Editor.

The Edit menu contains 9 commands, most of which are standard
for the edit windows (Title and Text), but have special meaning
for the Examples window (see also p.3. - "The Examples window").

Undo - if an edit window has the input focus, undoes the last
change in that window; if the Examples window has the input focus
- undoes the last deleted attribute or example.

cut - if an edit window has the input focus, cuts the selected
text and copies it to the clipboard. If the Exampleswindow has

the input focus - cuts an attribute or example and copies it to
the clipboard in text format.
Copy - if an edit window has the input focus, copies the

selected text to the clipboard. If the Examples window has the
input focus - copies an attribute or example to the clipboard in
text format.

Paste - if an edit window has the input focus, pastes the text
from the clipboard to the current position of the caret. If the
Examples window has the input focus - pastes the text from the
clipboard to a new attribute or example.

Delete - if an edit window has the input focus, deletes the
selected text. If the Examples window has the input focus -
deletes an attribute or an example.

Insert - if the Examples window has the input focus, inserts a
new attribute or a new example.

Optimize - finds the optimal sequence of attributes and
reorders the attributes, if necessary.
Decision Tree - displays or hides the decision tree which

corresponds to the current set of examples. Changing selected
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attribute in the tree will automatically update the contents of
the Text and Values windows similarly to changing the selected
attribute in the examples table.

Test - evokes test of running the consultation course (see
also p.4. - "More about attributes. Testing expert knowledge
base") .

The Help menu contains commands providing some help about
using Expert Editor:

Index,

Keyboard,

Commands,

Procedures,

Using Help,

About Expert Editor.

3. The Examples window

The Examples window has standard features for up-down and
left-right scrolling. The selected cell can be changed by mouse
click or using the arrow keys. If you click at the example number
or move by the left arrow key to it, the whole example will be
selected. The last example is always empty, you can use it for
adding new examples.

If you wish to edit the text of a selected cell (attribute
name or example value), it can be done after mouse double-click
or pressing the Enter key. After editing the text press Enter
once again or click mouse outside the editing field.

The Values 1listbox can be used for changing an example
valuefor some other value of the same attribute. The selected
value in the Examples window will be changed after you choose the
new value in the Values listbox and press Enter, or double-click
the mouse button.

The Edit menu commands for the Examples window evoke the
following actions:

Undo - undoes the last deleted attribute or example.

cut - cuts an attribute (if the attribute name was selected)
or an example (if the whole example was selected). The attribute
or example will be copied to the clipboard in text format; the
vertical bar "|" is used as a delimiter separating the attribute
name and example values.

Copy - copies an attribute (if the attribute name was
selected) or an example (if the whole example was selected) to
the clipboard in text format; the vertical bar "|" is used as a
delimiter separating the attribute name and example values.

Paste - pastes the text from the clipboard to a new attribute
(if an attribute name was selected) or a new example (if an
example was selected). The vertical bar "|" is assumed to be a
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delimiter.
Delete - deletes an attribute (if the attribute name or an

example value was selected) or an example (if the whole example
was selected). It is possible to restore the deleted attribute or
example using the Undo command.

Insert - inserts a new attribute (if an attribute name or an
example value was selected) or a new example (if an example was
selected). The values of the new attribute or example will be

"don't care" values ("-") by default.

Optimize - finds the optimal sequence of attributes and
reorders the attributes, if necessary.

Decision tree - displays the decision tree which corresponds

to the current set of examples. Changing selected attribute in
the tree will automatically update the contents of the Text and
Values windows similarly to changing the selected attribute in

the examples table.
Test - evokes test of running the consultation course.

4. More about attributes. Testing expert knowledge base

In order to organize the interaction of the expert system and
other parts of ExpertPRIZ, special attributes - message and
comparison attributes - have to be used in expert knowledge.

Values of the message attributes are sent to Solver when the
expert system is in action. They are interpreted as statements in
the input language of ExpertPRIZ. Message attributes do not
generate different paths in decision tree - they are just
interruptions to ask questions to follow the decision tree for
the purpose of carrying out necessary actions by Solver.

Comparison attributes are intended for control of the expert
system according to results of computations. Values of comparison
attributes are interpreted as logical conditions on the objects
from the problem model. These conditions specify different paths
in decison tree.

In short, there are four different types of attributes in the
Expert subsystem of ExpertPRIZ. The type of attribute determines
the action carried out during the consultation.

NB! As far as Expert Editor is concerned, there is no
difference between the types of attributes (except in the test
mode) . The following is included for better understanding of the
contents of the other .EXP files belonging to the set of files of
the demonstration of ExpertPRIZ.



The types of attributes are following:
1) Choice attributes

The name of choice attribute may be any text except "2", "<",
|l>ll.

In the consultation course the user is asked the question
related to this attribute, and a list of possible answers is
displayed. After the user's choice, the corresponding path of
the decision tree will be followed.

2) Message attributes

The name of message attribute is question mark ("?2").

The values corresponding to the message attributes in the
examples are statements in the input language of Solver.

In the consultation course ExpertPRIZ executes the different
statements which belong to the path of the decision tree
currently followed.

3) Comparison attributes

The name of comparison attribute is either ">" or "<,

The values corresponding to the comparison attribute are
conditions in the following form:

i) a e B,
where @ belongs to {=, <, >, <=, >=, <>}; A and B may be either
constants or names of objects having values in the moment of

comparison.

ii) < object name > - is considered to be valid, if the
object has got a value.

iii) ! < object name > - is considered to be valid, if the

object exists in the problem model but has got no value.

In case of comparison attributes the system checks whether the
conditions are fulfilled and follows the paths for which the
condition is valid.

4) Result attribute

The last attribute in expert knowledge base is always
considered to be the result attribute.

If the value of the result attribute begins with the sign "#"
followed by an expert knowledge base name, then during the
consultation the system automatically switches to that knowledge
base. This facility, called chaining expert knowledge bases,
allows to build expert systems with quite complicated structures.

A result value not beginning with "#" may be a decision, a
diagnosis, or an answer, and 1is output as the result of the
consultation.

In Expert Editor it is possible to test the expert knowledge
base currently open. You can check how the expert system that you
have just created or updated will behave during the consultation
course. For that purpose choose Test from the Edit menu. It
starts a dialog which leads you through the decision tree from
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the root node to some leaf node, corresponding to the result of
consultation.

NB! In the test mode it is not possible to interact with
Solver or other parts of ExpertPRIZ, neither is there an
underlying problem model!

In the test mode, while processing message attributes, you can
only view the statements which should be sent to Solver, in a
listbox. While processing comparison attributes, you have to
indicate the valid conditions yourself - choose from the
multiple-selection listbox those comparison conditions which have
to be considered true.

There is also a difference in processing result attributes.
Since Expert Editor works with one expert knowledge base at a
time, it does not switch to another expert knowledge base while
testing. In the case of chaining expert knoledge bases you can
only see the chaining command as a result of consultation.

In the case of choice attributes the test mode corresponds
exactly to the consultation course you can evoke through
ExpertPRIZ. Check it testing the CONIFERS.EXP expert knowledge
base!



